#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d+(\d{1,3})*([\,\ ]\d{3})*\.\d+)?.+(sqft)"
Local $sString = ""4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm"" & @CRLF & _
""4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")