package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d+(\d{1,3})*([\,\ ]\d{3})*\.\d+)?.+(sqft)`)
var str = `"4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm"
"4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}