using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d+(\d{1,3})*([\,\ ]\d{3})*\.\d+)?.+(sqft)";
string input = @"""4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm""
""4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}