import Foundation
let pattern = #"[0-9]+[a-zA-Z]?(\/[0-9]+[a-zA-Z])?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1111111c/1111111
11a/111b
11/11a
11/112
111121112
1111111C/
1111111c/
/1111111c
ccccccc/11111
1111/cccc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)