import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+[a-zA-Z]?(\\/[0-9]+[a-zA-Z])?";
final String string = "1111111c/1111111\n"
+ "11a/111b\n"
+ "11/11a\n"
+ "11/112\n"
+ "111121112\n\n"
+ "1111111C/\n"
+ "1111111c/\n"
+ "/1111111c\n"
+ "ccccccc/11111\n"
+ "1111/cccc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}