package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+[a-zA-Z]?(\/[0-9]+[a-zA-Z])?`)
var str = `1111111c/1111111
11a/111b
11/11a
11/112
111121112
1111111C/
1111111c/
/1111111c
ccccccc/11111
1111/cccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}