# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[0-9]+[a-zA-Z]?(\/[0-9]+[a-zA-Z])?"
test_str = ("1111111c/1111111\n"
"11a/111b\n"
"11/11a\n"
"11/112\n"
"111121112\n\n"
"1111111C/\n"
"1111111c/\n"
"/1111111c\n"
"ccccccc/11111\n"
"1111/cccc")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.