const regex = /[0-9]+[a-zA-Z]?(\/[0-9]+[a-zA-Z])?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+[a-zA-Z]?(\\\/[0-9]+[a-zA-Z])?', 'g')
const str = `1111111c/1111111
11a/111b
11/11a
11/112
111121112
1111111C/
1111111c/
/1111111c
ccccccc/11111
1111/cccc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}