// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))").unwrap();
let string = "pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea";
let substitution = "$1$4$3ay";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}