use strict;
my $str = 'pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea';
my $regex = qr/([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))/ip;
my $subst = '$1$4$3ay';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";