import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))";
final String string = "pig\n"
+ "trash\n"
+ "egg\n"
+ "inbox\n"
+ "eight\n"
+ "hello\n"
+ "yahoo\n"
+ "spoonfull\n"
+ "spleen\n"
+ "flea";
final String subst = "$1$4$3ay";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}