$re = '/([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))/i';
$str = 'pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea';
$subst = "$1$4$3ay";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;