package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))`)
var str = `pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea`
var substitution = "$1$4$3ay"
fmt.Println(re.ReplaceAllString(str, substitution))
}