$re = '/^[ \-0-9a-zA-ZäöüÄÖÜß.]+?\s+(\d+(\s?[a-zA-Z])?)\s*(?:$|\(|[A-Z]{2})/m';
$str = 'Straßenname 1
Straßenname 123
Straßen-name 1
Straßen name 1
Straßenname 1a
Straßenname 1 a
Straßenname 1 A
Straßenname 123/a
Straßenname 123-a
Straßenname
Straßenname a
Straßenname 1ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);