#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ \-0-9a-zA-ZäöüÄÖÜß.]+?\s+(\d+(\s?[a-zA-Z])?)\s*(?:$|\(|[A-Z]{2})"
Local $sString = "Straßenname 1" & @CRLF & _
"Straßenname 123" & @CRLF & _
"Straßen-name 1" & @CRLF & _
"Straßen name 1" & @CRLF & _
"Straßenname 1a" & @CRLF & _
"Straßenname 1 a" & @CRLF & _
"Straßenname 1 A" & @CRLF & _
"Straßenname 123/a" & @CRLF & _
"Straßenname 123-a" & @CRLF & _
"" & @CRLF & _
"Straßenname" & @CRLF & _
"Straßenname a" & @CRLF & _
"Straßenname 1ab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")