import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\-0-9a-zA-ZäöüÄÖÜß.]+?\\s+(\\d+(\\s?[a-zA-Z])?)\\s*(?:$|\\(|[A-Z]{2})";
final String string = "Straßenname 1\n"
+ "Straßenname 123\n"
+ "Straßen-name 1\n"
+ "Straßen name 1\n"
+ "Straßenname 1a\n"
+ "Straßenname 1 a\n"
+ "Straßenname 1 A\n"
+ "Straßenname 123/a\n"
+ "Straßenname 123-a\n\n"
+ "Straßenname\n"
+ "Straßenname a\n"
+ "Straßenname 1ab";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}