const regex = /^[ \-0-9a-zA-ZäöüÄÖÜß.]+?\s+(\d+(\s?[a-zA-Z])?)\s*(?:$|\(|[A-Z]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\-0-9a-zA-ZäöüÄÖÜß.]+?\\s+(\\d+(\\s?[a-zA-Z])?)\\s*(?:$|\\(|[A-Z]{2})', 'gm')
const str = `Straßenname 1
Straßenname 123
Straßen-name 1
Straßen name 1
Straßenname 1a
Straßenname 1 a
Straßenname 1 A
Straßenname 123/a
Straßenname 123-a
Straßenname
Straßenname a
Straßenname 1ab`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}