use strict;
my $str = 'Straßenname 1
Straßenname 123
Straßen-name 1
Straßen name 1
Straßenname 1a
Straßenname 1 a
Straßenname 1 A
Straßenname 123/a
Straßenname 123-a
Straßenname
Straßenname a
Straßenname 1ab';
my $regex = qr/^[ \-0-9a-zA-ZäöüÄÖÜß.]+?\s+(\d+(\s?[a-zA-Z])?)\s*(?:$|\(|[A-Z]{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}