re = /console\.log\(('|\")?(.*)+('|\")?\)/mi
str = 'console.log(editedItem)
console.log(\'editedItem\')
console.log("editedsdfbzgf_Sfgblmeùgbklnegkbln (){}<>Item)
zerg
zrtg
bzr
gt '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end