package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)console\.log\(('|\")?(.*)+('|\")?\)`)
var str = `console.log(editedItem)
console.log('editedItem')
console.log("editedsdfbzgf_Sfgblmeùgbklnegkbln (){}<>Item)
zerg
zrtg
bzr
gt `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}