#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)console\.log\(('|\")?(.*)+('|\")?\)"
Local $sString = "console.log(editedItem)" & @CRLF & _
" console.log('editedItem')" & @CRLF & _
" console.log("editedsdfbzgf_Sfgblmeùgbklnegkbln (){}<>Item)" & @CRLF & _
"zerg" & @CRLF & _
"zrtg" & @CRLF & _
"bzr" & @CRLF & _
"gt "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")