$re = '/console\.log\((\'|\")?(.*)+(\'|\")?\)/mi';
$str = 'console.log(editedItem)
console.log(\'editedItem\')
console.log("editedsdfbzgf_Sfgblmeùgbklnegkbln (){}<>Item)
zerg
zrtg
bzr
gt ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);