import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "console\\.log\\(('|\\\")?(.*)+('|\\\")?\\)";
final String string = "console.log(editedItem)\n"
+ " console.log('editedItem')\n"
+ " console.log(\"editedsdfbzgf_Sfgblmeùgbklnegkbln (){}<>Item)\n"
+ "zerg\n"
+ "zrtg\n"
+ "bzr\n"
+ "gt ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}