import Foundation
let pattern = #"src="[^"]*\/kultpohod\/userfiles\/([^"]*)"[^>]*style="([^"]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img alt="" src="/kultpohod/userfiles/file/2015/08/07/kappes.ru-5884a6f2b97671c68c024bebcb2b7531dc4b.jpg" style="width: 500px; height: 375px;">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}