re = /^(?:[^\x00-\xff]|[a-zA-Z0-9\-_])+$/m
str = '测试(奥术大师多)sadas-】【暗示法看没看】
sadasfasf-=
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end