package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^\x00-\xff]|[a-zA-Z0-9\-_])+$`)
var str = `测试(奥术大师多)sadas-】【暗示法看没看】
sadasfasf-=
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}