$re = '/^(?:[^\x00-\xff]|[a-zA-Z0-9\-_])+$/m';
$str = '测试(奥术大师多)sadas-】【暗示法看没看】
sadasfasf-=
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);