using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^\x00-\xff]|[a-zA-Z0-9\-_])+$";
string input = @"测试(奥术大师多)sadas-】【暗示法看没看】
sadasfasf-=
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}