const regex = /^(?:[^\x00-\xff]|[a-zA-Z0-9\-_])+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^\\x00-\\xff]|[a-zA-Z0-9\\-_])+$', 'gm')
const str = `测试(奥术大师多)sadas-】【暗示法看没看】
sadasfasf-=
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}