re = /((\d+).*)(\.html)/
str = '2020-spisok-shindlera.html
/god/1993.html
dramy.html
zarubezhnye-serialy.html
strana/США.html
rezhissjor/Дэвид+Наттер.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end