package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d+).*)(\.html)`)
var str = `2020-spisok-shindlera.html
/god/1993.html
dramy.html
zarubezhnye-serialy.html
strana/США.html
rezhissjor/Дэвид+Наттер.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}