const regex = new RegExp('((\\d+).*)(\\.html)', 'g')
const str = `2020-spisok-shindlera.html
/god/1993.html
dramy.html
zarubezhnye-serialy.html
strana/США.html
rezhissjor/Дэвид+Наттер.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}