import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d+).*)(\\.html)";
final String string = "2020-spisok-shindlera.html\n"
+ "/god/1993.html\n"
+ "dramy.html\n"
+ "zarubezhnye-serialy.html\n"
+ "strana/США.html\n"
+ "rezhissjor/Дэвид+Наттер.html";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}