using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+).*)(\.html)";
string input = @"2020-spisok-shindlera.html
/god/1993.html
dramy.html
zarubezhnye-serialy.html
strana/США.html
rezhissjor/Дэвид+Наттер.html";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}