const regex = /([A-Z]{3})(20\d{2})(\d{9})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]{3})(20\\d{2})(\\d{9})\\b', 'g')
const str = `PRK2017000003021
PRK2017000003017
AAA2017000000000
aaa2017956639163
Aaa2017956639163
AAa2017956639163
aAA2017956639163
DMY2017817027421
PRK2017000003022
PRK2017000003023
PRN2017000000001
IHR2018000000001
IHR2018000000002
IHR2018000000003a
DMY20180112150945`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}