# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-Z]{3})(20\d{2})(\d{9})\b"
test_str = ("PRK2017000003021\n"
"PRK2017000003017\n"
"AAA2017000000000\n"
"aaa2017956639163\n"
"Aaa2017956639163\n"
"AAa2017956639163\n"
"aAA2017956639163\n"
"DMY2017817027421\n"
"PRK2017000003022\n"
"PRK2017000003023\n"
"PRN2017000000001\n"
"IHR2018000000001\n"
"IHR2018000000002\n"
"IHR2018000000003a\n"
"DMY20180112150945")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.