package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]{3})(20\d{2})(\d{9})\b`)
var str = `PRK2017000003021
PRK2017000003017
AAA2017000000000
aaa2017956639163
Aaa2017956639163
AAa2017956639163
aAA2017956639163
DMY2017817027421
PRK2017000003022
PRK2017000003023
PRN2017000000001
IHR2018000000001
IHR2018000000002
IHR2018000000003a
DMY20180112150945`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}