import Foundation
let pattern = #"(?:href\=\')([\s\S]*?)(?=\'\>Link)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Attempt 1 out of 1 has failed for workflow with an error message - Response check returned False.<br><br><b>Workflow</b>: prod_low_mozrt_demo_1c_2gb <br> <b>Workflow ID</b>: 18314 <br> <b>Job Name</b>: 288451 <br> <b>Node Name</b>: node_1<br><br>Please click on the log link for details: <a href='https://ml.prod.walmart.com:31999/projects/8390/workflows/18314/dag_18314_a1dde758-62df-49e4-8a88-69222f74afff/logs/deployment-airflow?execution_date=2021-12-06T17:32:00&task_id=node_1'>Link</a><br>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}