import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:href\\=\\')([\\s\\S]*?)(?=\\'\\>Link)";
final String string = "Attempt 1 out of 1 has failed for workflow with an error message - Response check returned False.<br><br><b>Workflow</b>: prod_low_mozrt_demo_1c_2gb <br> <b>Workflow ID</b>: 18314 <br> <b>Job Name</b>: 288451 <br> <b>Node Name</b>: node_1<br><br>Please click on the log link for details: <a href='https://ml.prod.walmart.com:31999/projects/8390/workflows/18314/dag_18314_a1dde758-62df-49e4-8a88-69222f74afff/logs/deployment-airflow?execution_date=2021-12-06T17:32:00&task_id=node_1'>Link</a><br>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}