#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:href\=\')([\s\S]*?)(?=\'\>Link)"
Local $sString = "Attempt 1 out of 1 has failed for workflow with an error message - Response check returned False.<br><br><b>Workflow</b>: prod_low_mozrt_demo_1c_2gb <br> <b>Workflow ID</b>: 18314 <br> <b>Job Name</b>: 288451 <br> <b>Node Name</b>: node_1<br><br>Please click on the log link for details: <a href='https://ml.prod.walmart.com:31999/projects/8390/workflows/18314/dag_18314_a1dde758-62df-49e4-8a88-69222f74afff/logs/deployment-airflow?execution_date=2021-12-06T17:32:00&task_id=node_1'>Link</a><br>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")