use strict;
my $str = 'Attempt 1 out of 1 has failed for workflow with an error message - Response check returned False.<br><br><b>Workflow</b>: prod_low_mozrt_demo_1c_2gb <br> <b>Workflow ID</b>: 18314 <br> <b>Job Name</b>: 288451 <br> <b>Node Name</b>: node_1<br><br>Please click on the log link for details: <a href=\'https://ml.prod.walmart.com:31999/projects/8390/workflows/18314/dag_18314_a1dde758-62df-49e4-8a88-69222f74afff/logs/deployment-airflow?execution_date=2021-12-06T17:32:00&task_id=node_1\'>Link</a><br>
';
my $regex = qr/(?:href\=\')([\s\S]*?)(?=\'\>Link)/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}