# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:href\=\')([\s\S]*?)(?=\'\>Link)"
test_str = ("Attempt 1 out of 1 has failed for workflow with an error message - Response check returned False.<br><br><b>Workflow</b>: prod_low_mozrt_demo_1c_2gb <br> <b>Workflow ID</b>: 18314 <br> <b>Job Name</b>: 288451 <br> <b>Node Name</b>: node_1<br><br>Please click on the log link for details: <a href='https://ml.prod.walmart.com:31999/projects/8390/workflows/18314/dag_18314_a1dde758-62df-49e4-8a88-69222f74afff/logs/deployment-airflow?execution_date=2021-12-06T17:32:00&task_id=node_1'>Link</a><br>\n")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.