import Foundation
let pattern = #"""
[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\s[0-9]
|[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\-[0-9]
|[A-Z]{4}\s[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}[0-9]
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ARKU 851 512 1
ARKU 851 512-1
ARKU 851512-1
ARKU851512-1
ARKU8515121
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)