$re = '/[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\s[0-9]
|[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\-[0-9]
|[A-Z]{4}\s[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}[0-9]/';
$str = 'ARKU 851 512 1
ARKU 851 512-1
ARKU 851512-1
ARKU851512-1
ARKU8515121
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);