const regex = /[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\s[0-9]
|[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\-[0-9]
|[A-Z]{4}\s[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}[0-9]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]{4}\\s[0-9]{3}+\\s+[0-9]{3}\\s[0-9]
|[A-Z]{4}\\s[0-9]{3}+\\s+[0-9]{3}\\-[0-9]
|[A-Z]{4}\\s[0-9]{6}\\-[0-9]
|[A-Z]{4}[0-9]{6}\\-[0-9]
|[A-Z]{4}[0-9]{6}[0-9]', 'g')
const str = `ARKU 851 512 1
ARKU 851 512-1
ARKU 851512-1
ARKU851512-1
ARKU8515121
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}