using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\s[0-9]
|[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\-[0-9]
|[A-Z]{4}\s[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}[0-9]";
string input = @"ARKU 851 512 1
ARKU 851 512-1
ARKU 851512-1
ARKU851512-1
ARKU8515121
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}