import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{4}\\s[0-9]{3}+\\s+[0-9]{3}\\s[0-9]\n"
+ "|[A-Z]{4}\\s[0-9]{3}+\\s+[0-9]{3}\\-[0-9]\n"
+ "|[A-Z]{4}\\s[0-9]{6}\\-[0-9]\n"
+ "|[A-Z]{4}[0-9]{6}\\-[0-9]\n"
+ "|[A-Z]{4}[0-9]{6}[0-9]";
final String string = "ARKU 851 512 1\n"
+ "ARKU 851 512-1\n"
+ "ARKU 851512-1\n"
+ "ARKU851512-1\n"
+ "ARKU8515121\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}