// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"assert\.strictEqual\((.*), (.*)\);").unwrap();
let string = " assert.strictEqual(wrapper.type(), ButtonBase);
assert.strictEqual(wrapper.hasClass(classes.root), true);
assert.strictEqual(wrapper.hasClass('woofCollapseSectionSummary'), true);
assert.strictEqual(itemsWrap.hasClass(classes.content), true);
assert.strictEqual(wrapper.hasClass(classes.disabled), true);
assert.strictEqual(wrapper.hasClass(classes.expanded), true);
assert.strictEqual(iconWrap.hasClass(classes.expandIcon), true);
assert.strictEqual(wrapper.state().focused, true);
assert.strictEqual(wrapper.state().focused, false);
assert.strictEqual(handleChange.callCount, 1);
assert.strictEqual(handleChange.calledWith(eventMock), true);
assert.strictEqual(handleChange.callCount, 0);
assert.strictEqual(handleClick.callCount, 1);
";
let substitution = "expect($1).toEqual($2);";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}