import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "assert\\.strictEqual\\((.*), (.*)\\);";
final String string = " assert.strictEqual(wrapper.type(), ButtonBase);\n"
+ " assert.strictEqual(wrapper.hasClass(classes.root), true);\n"
+ " assert.strictEqual(wrapper.hasClass('woofCollapseSectionSummary'), true);\n"
+ " assert.strictEqual(itemsWrap.hasClass(classes.content), true);\n"
+ " assert.strictEqual(wrapper.hasClass(classes.disabled), true);\n"
+ " assert.strictEqual(wrapper.hasClass(classes.expanded), true);\n"
+ " assert.strictEqual(iconWrap.hasClass(classes.expandIcon), true);\n"
+ " assert.strictEqual(wrapper.state().focused, true);\n"
+ " assert.strictEqual(wrapper.state().focused, false);\n"
+ " assert.strictEqual(handleChange.callCount, 1);\n"
+ " assert.strictEqual(handleChange.calledWith(eventMock), true);\n"
+ " assert.strictEqual(handleChange.callCount, 0);\n"
+ " assert.strictEqual(handleClick.callCount, 1);\n";
final String subst = "expect($1).toEqual($2);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}