# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"assert\.strictEqual\((.*), (.*)\);"
test_str = (" assert.strictEqual(wrapper.type(), ButtonBase);\n"
" assert.strictEqual(wrapper.hasClass(classes.root), true);\n"
" assert.strictEqual(wrapper.hasClass('woofCollapseSectionSummary'), true);\n"
" assert.strictEqual(itemsWrap.hasClass(classes.content), true);\n"
" assert.strictEqual(wrapper.hasClass(classes.disabled), true);\n"
" assert.strictEqual(wrapper.hasClass(classes.expanded), true);\n"
" assert.strictEqual(iconWrap.hasClass(classes.expandIcon), true);\n"
" assert.strictEqual(wrapper.state().focused, true);\n"
" assert.strictEqual(wrapper.state().focused, false);\n"
" assert.strictEqual(handleChange.callCount, 1);\n"
" assert.strictEqual(handleChange.calledWith(eventMock), true);\n"
" assert.strictEqual(handleChange.callCount, 0);\n"
" assert.strictEqual(handleClick.callCount, 1);\n")
subst = "expect($1).toEqual($2);"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.